Personal tools

Difference between revisions of "Ace:Audit Manager Upgrading"

From Adapt

Jump to: navigation, search
Line 54: Line 54:
 
; 5. Update any configuration settings. (Versions prior to 1.3)
 
; 5. Update any configuration settings. (Versions prior to 1.3)
 
: In your TOMCAT/conf/Catalina/localhost/ace-am.xml file, you may need to add some settings. This is only needed if you are upgrading from 1.2.2 or earlier.
 
: In your TOMCAT/conf/Catalina/localhost/ace-am.xml file, you may need to add some settings. This is only needed if you are upgrading from 1.2.2 or earlier.
: Add the following lines to your configuration file, after the '<Resource auth....' section.
+
 
  <!--Mail server to use when mailing reports. You will need to set this if
+
: Check the following line in your configuration file to ensure the database connection uses UTF-8.
  you want reports to be mailed properly.-->
+
    <Resource auth="Container" driverClassName="com.mysql.jdbc.Driver" maxActive="20"
  <Parameter name="mail.server" value="localhost.localdomain"/>
+
      maxIdle="10" maxWait="-1" name="jdbc/aceamdb"
  &lt;!-- Set this e-mail address to an address e-mail should originate from -->
+
      password="ace" username="aceam"  
  <Parameter name="mail.from" value="aceam@localhost"/>
+
      url="jdbc:mysql://localhost/aceam?characterEncoding=UTF-8"
: These two settings specify a mail server and e-mail address to use when sending out reports. You should change these if the server running ACE does not run a mail server. Check with your sysadmin if you are not sure. On most unix systems, you can just use these defaults. For windows, talk to your system administrator for the correct settings.
+
      testOnBorrow="true" type="javax.sql.DataSource" validationQuery="SELECT 1"/>
 +
 
 +
: If your url does not contain the character encoding, you will need to add it if you want to use UTF-8 characters.
 +
 
 
: There is a sample configuration file available [http://narademo.umiacs.umd.edu/aceam/current/ace-am.xml here]
 
: There is a sample configuration file available [http://narademo.umiacs.umd.edu/aceam/current/ace-am.xml here]
 
; 6. Restart ACE.
 
; 6. Restart ACE.

Revision as of 17:24, 14 September 2012

Upgrade Instructions

There are three steps to upgrading the audit manager, these are upgrading the application code, upgrading the underlying database, and finally updating any configuration files if necessary. The procedure for upgrading is listed below

These instructions are current for version 1.3. Links to all previous versions of ace are available on the software page

1. Note the version you are currently running
Point your web browser at your ACE AM installation and look for the version at the bottom. If should look something like 1.2.2, or 1.3..
2. Stop the Audit Manager/Tomcat
Run TOMCAT/bin/shutdown.sh to stop tomcat
[toaster@loach ~/aceam]$ apache-tomcat-6.0.18/bin/shutdown.sh 
Using CATALINA_BASE:   /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18
Using CATALINA_HOME:   /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18
Using CATALINA_TMPDIR: /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18/temp
Using JRE_HOME:       /opt/jdk1.6.0
3. Apply database patches
Connect to your mysql database and apply any listed patches in order. You will need to apply all patches starting with your current version (see step 1) *in order*. See the table at the bottom of this page for a list of what patches you need.
To apply the patchec, connect to your database and issue the command 'source patchfile.sql' for each patch file you need to run.
Here's an example of what you will see. Depending on which patches you are applying, your screen will look different.
[user@loach ~]$ mysql aceam -u aceam -p 
Enter password: 
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 88
Server version: 5.0.45 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> source 1.2-1.3.updates.sql;
Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.01 sec)

Query OK, 0 rows affected (0.00 sec)
...
...
Query OK, 0 rows affected (0.00 sec)

mysql> 


4. Upgrade the ACE AM code
Remove the existing ACE installation files and directories located at TOMCAT/webapps/ace-am and TOMCAT/webapps/ace-am.war.
[toaster@loach ~/aceam]$ rm -rf apache-tomcat-6.0.18/webapps/ace-am*
Place a copy of the latest ace-am.war file in TOMCAT/webapps/
[toaster@loach ~/aceam]$ cp /tmp/ace-am.war apache-tomcat-6.0.18/webapps/
The latest version can be downloaded here
5. Update any configuration settings. (Versions prior to 1.3)
In your TOMCAT/conf/Catalina/localhost/ace-am.xml file, you may need to add some settings. This is only needed if you are upgrading from 1.2.2 or earlier.
Check the following line in your configuration file to ensure the database connection uses UTF-8.
    <Resource auth="Container" driverClassName="com.mysql.jdbc.Driver" maxActive="20"
     maxIdle="10" maxWait="-1" name="jdbc/aceamdb" 
     password="ace" username="aceam" 
     url="jdbc:mysql://localhost/aceam?characterEncoding=UTF-8" 
     testOnBorrow="true" type="javax.sql.DataSource" validationQuery="SELECT 1"/>
If your url does not contain the character encoding, you will need to add it if you want to use UTF-8 characters.
There is a sample configuration file available here
6. Restart ACE.
Run TOMCAT/bin/startup.sh to restart tomcat
[toaster@loach ~/aceam]$ apache-tomcat-6.0.18/bin/startup.sh 
Using CATALINA_BASE:   /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18
Using CATALINA_HOME:   /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18
Using CATALINA_TMPDIR: /fs/narahomes/toaster/aceam/apache-tomcat-6.0.18/temp
Using JRE_HOME:       /opt/jdk1.6.0_07


Database Files

Database patches required to bring ace database up to version 1.3.

Current Version Database Update Files
1.2.2 1.2-1.3.updates.sql
1.2.1 1.2-1.3.updates.sql
1.2 1.2-1.3.updates.sql
1.1 1.1-1.2.updates.sql
1.2-1.3.updates.sql
1.0 1.0-1.1.update.sql
1.1-1.2.updates.sql
1.2-1.3.updates.sql